XOOPSのXPressMEのphp7対応

php7を導入したところ、XOOPSでWordPress(モジュールXPressME)がうまく動作しないで、画面真っ白になってしまって困っていましたが、手作業で、この情報をもとにファイルを書き換えたところ、動作することを確認しました。

修正が必要なファイルは以下のとおりでした。

  • admin/index.php
  • class/xpressD3commentContent.class.php
  • include/memory_limit.php
  • include/oninstall.php
  • wp-content/plugins/xpressme/include/d3forum_comment_disp.php
  • wp-content/plugins/xpressme/include/d3forum_comment_synchro.php
  • wp-content/plugins/xpressme/include/user_sync_xoops.php
  • wp-content/plugins/xpressme/xpressme_class.php

修正箇所が多いですが、順番にやるしかないです。たぶん、patchコマンドを使えばいいのでしょうが、やり方がわからず、ちゃっちゃと手作業でしてしまいました。

これで、WordPressは動くようになりましたが、dbkmarkenはまだです。

スポンサーリンク
レクタングル大
レクタングル大

シェアする

  • このエントリーをはてなブックマークに追加

フォローする